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SNAP PAC RESTFUL API TO EXCEL SPREADSHEET TECHNICAL NOTE

About this Tutorial

This technical note describes how to read from and write to an Opto 22 SNAP PAC programmable automation
controller via the PAC's RESTful API, using Visual Basic for Applications (VBA) with Microsoft Excel. In this way
you can securely share I/O point and variable data in your SNAP PAC controller with an Excel spreadsheet.

If you have not already done so, download sample spreadsheets in the SNAP PAC RESTful API to Excel
Spreadsheet Example on our website at www.opto22.com. Once downloaded, you can immediately use them
to read and write to your SNAP PAC.

The download includes these files:

o Opto22_RESTfulPAC_ReadingWritingCharting.xlsx—A macro-enabled Excel file containing three
spreadsheets and Visual Basic code. These spreadsheets require only the name or IP address of a PAC and
the login and password for a user with Read and Write privileges. (See “Prerequisite: Setting Up the PAC”
on page 1.

«  JsonConverterbas—A third-party class for VBA created by MIT (copyright Tim Hall, https://github.com/
VBA-tools/VBA-JSON). This file is available for general use as long as the provisions in its copyright are
preserved.

. 2203_SNAP_PAC_RESTful_API_to_Excel_Spreadsheet_Technical Note.pdf—(This document)

The first part of this tech note explains the sample spreadsheets. The optional second part of the tech note
explains step by step how to create a spreadsheet of your own, if you wish to.

Questions about this tutorial can be addressed to Support@opto22.com.

About the RESTful API

The REST APl is a way for software applications to securely access data in an Opto 22 SNAP PAC controller by
making GET and POST requests. The complete Opto 22 RESTful APl is documented here:

http://developer.opto22.com/static/generated/pac-rest-api/swagger-ui/index.html

At this link you'll find URL paths to read any data available to the PAC Control strategy running on the PAC and
to write to the same data, if it is a writable data type. All the GET and POST requests return information in
standard JavaScript Object Notation (JSON).

The sample Excel file uses the PAC's RESTful APl and common Excel features to create an interactive
spreadsheet that can query your PAC and then build URL paths for the data in your control strategy. You don't
need to know the I/0 point and variable names on your PAC, because the Excel sample can read the 1/0 and
variable names and will create the paths. To see how to construct the HTTP requests and parse the returned
data, you'll look in the Visual Basic code included in the Excel sample. We'll explore the code below.

PREREQUISITE: SETTING UP THE PAC

Before you begin, enable the RESTful interface on the PAC and create a user account with read and write
privileges as described in the SNAP PAC REST API Quick Start, which is available at http://
developer.opto22.com/rest/pac/quickstart/
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If you're an experienced Excel user, you may wish to start by examining the sample file. The following images
provide an overview.

Reading spreadsheet

Choose a general type of data
to begin constructing a read
command. This drop-down
selects from I/0, variables, or
table variables.

This list is populated after you
select a general data type. The

selection you make completes a
read command that is sent to the
PAC. Both the read command and

return data appear in cells.

This list is populated after you
select a specific group. Make a

selection here to request a specific

item. The read command and
return data appearin cells.

Replace information in these fields with your
PAC's address and the username and
password that is defined on your PAC.

To use: Enter you PAC's domain njjme or IP address and the user nam} and password. Select general type of data to initiate searct

Provide IP Addreks  http://restpac.groov.com  Efamples: http://10.1.15.1 https://102.20.123.54
User nanfle: ro
Passwolf: ro
- [ -]
e [ '»] (select new value from menu to call for data)
= - . [ '»] (select new value from menu to call for data)
Enter index (if a table variable): (Leave index blank to get the whole table)
URL to PAC:
Re-send JSON returned:
Clear values Value(s) parsed:

Reading [ERUTET] Charting

®
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Writing spreadsheet

Enter the information to write in these fields. Each
cell is used for a different type of variable. The write
Replace the information in these fields with function in Excel will choose the appropriate field
your PAC's address and the username and based on the type of data you select.
password that is defined on your PAC.

ter you PAC's domain name or IP address and the user name and password. Selec
| i

atne or IP address and the user nanjle and password. Select generpl type of data to initiate searches.
Provide IP Addrefs  http://restpac.groov.com  Efamples: http://10.1.15.1 htjps://102.20.123.54

User namp: nw (tpgin must have read/write pgfmission)
Passworfl:

Use these three drop-down lists
to identify a specific I/O point,
variable, or table variable to
write to.

rw

Choose specific group:
Choose point or variable by name: ke

To read a specific table variable
index, type a valid index for the
table here. This field defaults to

If integer, float, or string

0 and is ignored if other than a _Re-send Read command | _ewrite | EEL
table variable is requested. | ol
String
If Discrate:
Click this button to re-send If array

the read command so you can
verify the write command.

[1,2.2,3.4,29, 60]
["string 1", "string 2"]
Start Index: T

URL Sent
Data Packet:
Returned:

FEEGI A Writing Charting @
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Charting spreadsheet

The Charting sheet shows how to call data on a timed interval. The data are displayed in cells and in a chart.

Replace the information in these fields with
your PAC's address and the username and
password that is defined on your PAC.

Use these three drop-down lists

to identify a specific /O point, _ E .
| [

variable or table variable to

(2}
(=}
m

write to.

Choose PAC:
To read a specific table variable Bl |pAC Address iy i T -
index, type a valid index for the 2 Hoer nAMmes gy
table here. This field defaults to 0 L : ujej pfsswordf L) e
and is ignored if other than a table = l =ll = = — -] 0580
variable is requested. Click the —— T 0.60
Update button to ensure that a 5 Add data graph e
change to a table index is included 3| Remove selected graph
in the data source. [l Graphsbeing plotted: | - b
1 0.00

The I/O point, variable, or table E: - Futd-Batinc s _Startmimer | 'HOCCOAM RGO 5
variable read command is _]:_ Timer interval (seconds) 0:00:07 iml
displayed here. Click Add data = A
graph to place the value in the 16 |
Graphs being plotted drop-down 17|
list. Select the item to remove it. 12 |

19

&
Be careful changing these values. |
The line value places the data iz
into the spreadsheet where the
chart will use it. If you change the
placement, you will also need to
change the chart.

3 Reading Writing Charting @
Type a new time interval if desired.
These buttons stop and start the live charting of data.
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VISUAL BASIC BEHIND THE SPREADSHEETS

E ~O— X .-C:ul_:

By Copy

‘D Paste
Grouping K
Order 3

%{ Format Control...

Assign Macro ? X

Macro name:
| Opto22_RESTfulPAC_readingWritingCharting xlsm!Sheetd.chot 5.5

Sheet3.dataClass A
Sheet3.dataFamily
Sheet3.newGraph

Sheet3 removeGraph
Sheet3 resendUrl

Sheet3 SelectMame

Sheet3 StartTimer

Sheet3, Stop_Timer
Sheetd.chooseGenType
Sheetd.choaseSpecificType
Sheetd clearValues

Edit

Sheetd resendUrl »
Macros in: | All Open Waorkbooks ~
Description

PAGE 5

The code that reads, writes, and plots data resides in the spreadsheet as modules and macros. Macros are run
from controls placed in the spreadsheet. To see the list of macros that can be assigned to a control (such as a
drop-down list or button), right-click the control.

To see the content of macros, first open the Visual Basic Editor. The VBA editor is available from the Developer
menu. Note that the Developer menu is not displayed by default.

To display the Developer menu:

1.

VoA W

Choose File -> Options.

In the options win, select Customize Ribbon.
Select Developer under Main Tabs and close the Options window.

Select the Developer menu.
Select the Visual Basic icon.

OPTO 22 - 800-321-6786 - 1-951-695-3000 - www.opto22.com - sales@opto22.com
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Each macro is defined by "Sub”
and "End Sub”

ﬁ Microseft Visual Basic for Applications - Opto22_RESTrulPAIC_readingWritingCharting.dsm

VBA code. The code for each
sheet was placed here for
organizational purposes.

The workbook code is a place
for commonly available
functions and startup routines.

JsonConverter is a module written
by MIT and made publicly available. ===
It may be used according to terms

of its copyright statement.

The Chart's timer public variables
and functions are contained in
this module.

OPTO 22 - 800-321-6786 - 1-951-695-3000 - www.opto22.com - sales@opto22.com

File Edit View |Insert Format Debug Run Todks Add-lns Window Help
E&E-d E » B IS FY © | n6 Col2e
‘pmjed.vwmjﬂi ﬁl _
=1= 1| [ QW T‘“ readingWritingChartingadsm - Sheet3 (Code) =
= ¥ veaproject (Opto22 | RESTFulPAC_ -

Sub StartTimer ()
Dim ws As Worksheet: Set ws = Worksheets("Charting™)
'get timer interval and starting line number
LineCount = ws.Range ("B12") .Value
TimerInterval = ws.Range ("B13") .Value
Modulel.Start_Timer|

End Sub

Stop Timer()

TimerActive = False

End Sub

removeGraph ()

Dim ws As Worksheet: Set ws = Worksheets("Charting™)
Dim dd As Object: Set dd = ws.DropDowns("_graphsDD")
If dd.listcount > O And dd.ListIndex > 0 Then

(General)

Public TimerActive As Boolean ‘global
Public LineCount As Integer 'global wvariable to
Public TimerTnterval As Date 'Single is a misma

Sub Start Timer()

TimerActive = True
Application.OnTime Now() + TimeValue ("00:00:08"), "Timer"™
' Bpplication.OnTime Now() + TimeValue ("0 08"), "TimerS
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(OPTIONAL) SETTING UP THE EXCEL DEVELOPMENT ENVIRONMENT

You can use the spreadsheets just as they are to read and write to your SNAP PAC. However, if you want to
understand more about how it was built or build your own, this last section shows you step by step how to
create a new spreadsheet, use the Visual Basic Editor, and write a macro to read data from your PAC.

If you are creating a new Excel spreadsheet, you will need to create a macro-enabled spreadsheet and add
resources to the Visual Basic editor.

Create a macro-enabled spreadsheet

1. Create a new file in Excel.
2. When saving, choose Excel Macro-Enabled Workbook.

When you save the file this way, the filename ends in xlsm.

Save As X

4 & » ThisPC » Documents v @ | Search Documents »p

n
4
(-]

Organize « New folder

& This PC
[ Desktop
@ Documents

; Downloads

J’ Music Adobe Custom Office PAC Project 9.5 -
Templates Examples

-
~

n

= Pictures

B videos

i, Local Disk ()

= Runtime (\\000eng.opto22.com) (G:)

m= HORME AANINShares nntn22 ol (HD e
File name: | Bookl.xdsx o
Save as type: | Excel Workbook (*xlsx) ~

Excel Workbook (*.xlsx)

Excel Macro-Enabled Workbook

Excel Binary Workbook (.xlsh)

Excel 7-2003 Workbook (*xls)

XML Data (*xml)

Single File Web Page (*.mht;*.mhtml)
. Hide Folders Web Page (".htm;".html)

Excel Template ("t

Excel Macro-Enabled Template (*xltm)
Excel 97-2003 Template (*xIt)

Text (Tab delimited) (*.bd)

Unicode Text (*txt)

XML Spreadsheet 2003 (*xml)
Micresoft Excel 5.0/93 Workbook (*.xls)
CSV (Comma delimited) (*.csv)
Formatted Text (Space delimited) (*.prm)
Text (Macintosh) (*.bxd)

Text (M5-DOS) (*.bet)

CSV (Macintosh) (*.csv)

C5V (M5-DOS) (*.csv)

DIF (Data Interchange Format) (*.dif)
SYLK (Symbuolic Link) (*.slk)

Excel Add-in (*.xlam)

Excel 97-2003 Add-in (*.xla)

PDF (*.pdf)

KPS Document (".xps)

Strict Open XML Spreadsheet (*xlsx)
OpenDocument Spreadsheet (*.ods)

Authors:

USA
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Enable the developer tool bar
1. Choose File > Options.
2. Choose Customize Ribbon.
3. Under Main Tabs, select Developer.
OptoRESTFUIPAC xlsm - Excel
o ~
Excel Options ? X
General . > "
=T Customize the Ribbon.
Formulas
— Choose commands from:(i Customize the Ribbon:
Skl Popular Commands Main Tabs =il
Save
Language ™ Add or Remove Filters EMain Tabs
All Chart Types... | ackground Removal
Advanced Borders |* ome
Save as Adobe Calculate Mow Clipboard
PDF Center Eont
Quick Access Toolbar EEI Sondibandl Formatting ’ Alignment
) Copy Number
Add-ins Custom Sort... Styles
dy Cut Cells
Trust Center A Decrease Font Size Editing
%’j Delete Cells... cert
* Delete Sheet Columns Padelrout
EX Delete Sheet Rows 9 ‘:"
- ‘% Email ormulas -
EL D Fill Color [» ata -
Font I eview
Publish A Font Color 1* ew
i . E
i
Format Cells 2 =ap=r

y,
Acc f

Options

Feedback

4. (Close the Options dialog box and return to the spreadsheet.

~

Format Painter
Freeze Panes
Increase Font Size
Insert Cells...
Insert Function...
Insert Picture
Insert Sheet Columns
Insert Sheet Rows
Insert Table
Macros

Merge & Center

-
ELaEE

n
a
&=

OPTO 22 - 800-321-6786 - 1-951-695-3000 - www.opto22.com - sales@opto22.com

-

Mew Tab MNew Group Rename...

Customizations: Reset = 6
| Import/Export ¥ @}

Cancel
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Open the Visual Basic editor
1. Choose the Developer tab.
2. Choose the Visual Basic button. This opens the VBA Editor in its own window.

H
o a Microsoft Visual Basic for Applications - Book1
File Edit View Inset Format Debug Run  Teols Add-lns Window Help
E-H fEa@ma 90 » TS =
Visual Basic (Alt+F11)

proset - s x|

=1=]F] |

Open the Visual Basic editor.

E-&% VBAProject (Book1)
| [=-£2§ Microsoft Excel Objects
i--Bf] Sheetl (Shest1)
-] ThisWorkbook
Sheet1 @
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The VBA editor defaults to a minimum set of libraries enabled. You will need to add more.

1. Choose Tools > References.

2. Find the following libraries and select each.

- Visual Basic For Applications

- Microsoft Excel 16.0 Object Library

—  OLE Automation

- Microsoft Office 16.0 Object Library

—  Microsoft Internet Controls

- Microsoft WinHTTP Services version 5.1

- Microsoft XML v6.0
- Microsoft Scripting Runtime

- Microsoft Forms 2.0 Object Library

a Microsoft Visual Basic for Applications - Book1

ifile Edit View |Insert Format Debug Run

Project - VBAProject X

=1E]=] B

& vBAProject (Book1)

= licrosoft Excel Objects
Sheetl (Sheet1)
ThisWorkbook

3. Click OKto close.

OPTO 22 - 800-321-6786 + 1-951-695-3000 - www.opto22.com - sales@opto22.com

Tools | Add-Ins  Window Help

EE- Rl o0 m

References...
Additional Controls...

Macros...

Optiens..

VBAProject | References - VBAProject

Digital Signg ;
Available References:

Wisual Basic For Applications

Microsoft Excel 16.0 Object Library
OLE Automation

Microsoft Office 16.0 Object Library
Microsoft Internet Controls

Microsoft WinHTTP Services, version 5.1
Microsoft XML, vé.0

Microsoft Scripting Runtime

Microsoft Forms 2.0 Object Library
UNSAVED: VBAProject
AccessibilityCpladmin 1.0 Type Library
Acrobat

Acrobat Access 3.0 Type Library
Arrnhat Distiller

A LD CCRI IR )RR R

Acrobat Scan 1.0 Type Library:

Location:  C:\Program Files (x86)\Adobe‘\Acrobat DCVAcrobat\plug_ins\s:
Language: Standard
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Create a Read command

Write code to read from the PAC

To read data from the PAC, you'll create a macro, which is Visual Basic code attached to the spreadsheet.

1. Inthe VBA Editor, double click “Sheet1” (or the name you used if you renamed the sheet).

2. Create a subroutine by typing: Sub ReadPoint()

As soon as you press Return, the text End Sub  will be added. All code added between Sub and
End Sub will make up the body of the macro.

In this tutorial, you'll enter the body of the macro in two parts. First, you'll enter the code that will retrieve
data and display it so that you can see the format of the data returned. Second, you will import a JSON
parsing module to convert the returned JSON string into an easy-to-use value.

3. Copy and paste (or type) the following text between Sub ReadPoint() and Sub End.Thetextis
annotated to explain what each section does. Lines beginning with an apostrophe are comments and
will appear in green in the VBA Editor. You'll need to customize the text in italics to your application as
described in the accompanying annotations.

" Create an object reference to the Excel worksheet
Dim ws As Worksheet: Set ws = Worksheets(''Sheetl')
"Create a string that will be the URL write command
Dim strUrl As String
“In the following line, substitute restpac.groov.com and
Lamp_Temperature/eu
‘with the address of your PAC and name of your point or variable. For
points, include “/eu”.
strUrl = "https://restpac.groov.com/api/vl/device/strategy/ios/
analoglnputs/Lamp_Temperature/eu
"Builld HTTP request
Dim hReq As New WinHttpRequest
hReq.Open "GET", strUrl, False
hReq.SetRequestHeader "Content-type'", "application/json"
hReqg.SetCredentials "username', "password"™, O "Replace username and
password with name and password
“defined for your PAC
hReq.Send
"Read the return from the PAC. The return information will be a JSON
string
Dim strResp As String
strResp = hReqg.ResponseText
“This will place the returned JSON string in cell 2B.
ws.Cells(2, 2).Value = strResp
After entering this code, your macro should appear as shown on the next page.
MADE IN THE
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E Microsoft Visual Basic for Applications - Book1.adsm
File Edit View |nset Format Debug Run  Tools Add-lns  Window Help
E-d Bl pon A EET @ 1o cls =
Project - VBAProject EJ [
21 Book?.xlsm - Sheetl (Code)
=l & = I m ;' IReadPoint L.l
El-&# VBAProject (Book1.xlsm) - —,
=)--£%3 Microsoft Excel Objects Sub ReadPoint() -
' Create an object reference to the Excel worksheet 1
Dim we As Worksheet: Set ws = Worksheets ("Sheetl"™)
'Create a string that will be the URL write command
i..g8? JsonConverter Dim strUrl As String
strlUrl = "http://restpac.groov.com/api/vl/device/strategy/ios/analoginputs/Lamp Temperature/eu”
'Build HITP reguest
Dim hReq &As New WinHttpReguest
hReq.0Open "GET", strOrl, False
hReq.S5etRequestHeader "Content-type”, "application/json”
hReq.S5etCredentials "rw", "rw", O 'Replace username and password with name and password defined
hReq.Send
'Read the return from the PAC. The return information will be a JSON string
Dim strResp As String
strResp = hReq.ResponseText
'Create an object using the JsonConverter library to read the walue from the JS0N string.
w2.Cells (2, 2).Value = strResp
' Dim json As Object =
Set json = JsonConverter.ParseJson(strResp) 'Use MIT JsonConverter class
Dim tempStr As String
temp5tr = json("value™)} '"value" is the name returned in the JS0N. For digital points, use "atate"
'See the Opto RESTful API for full set of returned names
'Display the parsed value in an cell
ws.Cellst3|, 2) .Value = tempStr 'Write the value to a cell
End Sub
-
==L | v
4. Saveyour changes.

Call the macro from the spreadsheet
1. Return to the Excel sheet.
2,

Resize columns A and B to provide space for drawing a button. Resize by positioning the mouse over the

column divider. When the cursor changes to a divider, click and drag the column divider.

Insert Page Layout Formulas Data

Add-  Excel COM
ins  Add-ins Add-ins
Add-ins

E Record Macro
| ﬁ Use Relative References

Visual Macros
Basic ! Macro Security
Code

3.

OPTO 22 - 800-321-6786 - 1-951-695-3000 - www.opto22.com - sales@opto22.com

Rex
rﬁ Map Properties @ Impaort
:% Expansion Packs Eﬂ.’ Export

M Properties
]

. EViewCoce

Insert Design
- Mode [4]Run Dialog

Controls

=

urce
{="1 Refresh Data

Click the Developer tab to display the Developer tools.
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4.  Open the list of Form Controls by clicking the Insert button, and choose the button icon (top left Form
Control in this picture):

Book] - Excel

Data Review View ACROBAT Q Te

M [ Properties EE

Home Insert Formulas

Page Layout

:D' !.j Record Macro ’ g ,g‘:*

% Map Properties @ Impart

= ﬁ Use Relative References = 7] View Code I% Expansion Packs @, Export
Visual Macros Add-  Excel COM Design urce
Basic ! Macro Security ins  Add-ins Add-ins Mode (4] Run Dizlog E1 Refresh Data

Code Add-ins Form Controls | XML

|§El@ﬂ©
Aa & Bl EE
ActiveX Controls
D v B
Healz2ll

5. Clickand drag in the spreadsheet to create the button.

Book] - Excel

Home  Inset  Pagelayout  Formulas  Data  Review  View ACROBAT Q@ Tell me

E::r 27 Record Macro a & E‘:* M E Properties @ FEMEP Properties @Impurl

B ﬁ Use Relative References ,,,‘% Expansion Packs E‘L Export
Visual Macros Add-  Excel COM Source
! Macro Security ins  Add-ins Add-ins E! Refresh Data

Code Add-ins

You can resize and reposition the button after you draw it.

As soon as you draw the button, a Macro window appears. The macro you created should be visible in

the window:
MADE IN THE
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Book1 xlsm - Excel

Home Insert Page Layout Formulas Data Review View ACROBAT Format

’ & ,;‘:* ﬂ M [ Properties EE T3 Map Properties B3 Impart

.j Record Macro

=L! ﬁ Use Relative References = 7] View Code I% Expansion Packs Fﬂ, Export
Visual Macros Add-  Excel COM Insert Design urce
Basic ! Macro Security ins  Add-ins Add-ins +  Mode 3] Run Dialog E1 Refresh Data

Code Add-ins Controls

Assign Macro
Macro name:
&, O ) =
& 5 Button1_Click] e New
i Sheetl.ReadPoint
O O O Record...
Macros in: | All Open Workbooks v
Description

6. Select Sheet1.ReadPoint and click OK.

7. Change the name of the new button by right-clicking the button. Position the cursor over the text, click
the text, and type a new name, such “Read Point.”

8. Test by clicking the Read Point button.

The return string appears in cell 2B:

Book1 xism - Excel

Home  Inset  Pagelayout  Formulas  Data  Review  View [SISRIE ACROBAT @ Tell me what

27 Record Macra a nﬁ G. ﬂ [=] Properties E EFi Map Properties [ Import

= —
-3 a S i My ot
Mdd- Bl COM | lnsert Desig - &lviewCode = I Exgansion Packs 1= Export

: Shier
! Macra Security ins Add-ins Add-ins |+  Mode 3] Run Dialog [ Refrech Data
Code Add-ins Contrals :

{"value":7.22704163e+01}

Read Point |

The return string’s value varies in type according to the type of data returned. This example returned a float
variable that needs to isolated from the string and converted to a standard number.

MADE IN THE

OPTO 22 - 800-321-6786 + 1-951-695-3000 + www.opto22.com - sales@opto22.com ESAE

©2016-2017 Opto 22. All rights reserved. Dimensions and specifications are subject to change. Brand or product names used herein are trademarks or registered trademarks of their respective companies or organizations.



OPTO 2222 SNAPPACRESTful API to Excel Spreadsheet

Form 2203-170911
PAGE 15
Parse the JSON string
Import the JsonConverter module.
1. Inthe VBA Editor, choose File > Import File.
2. Navigate to the file JsonConverter.bas, select it, and choose Open.
£ Microsoft Visual Basic for Applications - Book1xlsm
File | Edit View Insert Format Debug Run Tools Add-lns  Window Help
|d  Save Booklxism 45 W% @ | Ln26 ol B
P Import File... Ctrl+|
Export File... Ctrl+E
Ll j iReadPoinl
- .
& Print.. CtrisP £ Import File X
X Close and Return te Microsoft Excel  Alt+Q M » ThisPC » Local Disk (C:) » restful_pac » VBA-JSON-master » v O Search VBA-JSON-master p
D Organize New folder - O @
at] A
| EThisec @ tome
Dif [ Desktop specs
nR| = | JsonConverterbas
2 & Documents U
ng) 4 Downloads
B b Music
'R| (=] Pictures
2 videos
L ‘i Local Disk (C:)
l == Runtime (\\000eng.opte22.com) (G:) Mo preview available.
== HOME (\\000Shares.cpto22.com) (H:)
End 39 UsEs (W000MKing.opto22.com) (1)
= USEe (\\000Eng.cpto22.com) (1)
== NETAPPS (\\000Shares.opto22.com) (K:)
== OFF_2k_1 (\\000Shares.opto22.com) (M:)
== OFF_2k_2 (\\000Shares.opto22.com) (N:)
== OUTLK_2003 (\\000Shares.opto22.com) (0]
= Production (\\000Eng.epto22.com) (Q:) il 5
File name: [JsonConverter.bas ||V Files ¢ frm;* bas;*.cls) v

The JsonConverter module appears in the Project tree. Expand the Modules folder to see the
JsonConverter. You do not need to open JsonConverter for this tutorial.

E Microsoft Visual Basic for Applications - Book1.xlsm
File Edit View Inset Format Debug Run  Tools Add-lns  Window Help

HE-d P HEFE O
IProject - VBAProject _?SJ

) Bookl.xlsm - Sheet1 (Code)
= [i M

E-8% VBAProject (Bookl.xlsm)
-3 Microsoft Excel Objects 3ub ReadPoint ()
Sheetl (Sheet1) ' Create an object reference to the Excel wo:
@ThlsWorkboak Dim w3 As Worksheet: Set w3 = Worksheets("Sh
'Create a string that will be the URL write .
2% JsonConverter : Dim strUrl As String
strUrl = "http://restpac.groov.com/api/vl/de

'Build HTTP reguest

Dim hReq &s New WinHttpRegquest

hReq.Open "GET"™, strUrl, False
hReq.SetRequestHeader "Content-type™, "appli
hReqg.SetCredentials "username", "password™, !
hReq.Send

'Read the return from the PAC. The return in:
Dim strResp As String
strResp = hReq.ResponseText

'Create an object using the JsonConverter 1

ws.Cells (2, 2).Value = strResp

End Sub
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3. Add the following code at the end of your subroutine (macro) within the body of the macro:
"Create an object using the JsonConverter library to read the value
from the JSON string.

Dim json As Object

Set json = JsonConverter.ParseJson(strResp) “Use MIT JsonConverter
class

Dim tempStr As String

tempStr = json(“'value'™) ""value™ is the name returned in the JSON. For
digital points, use "state"

"See the Opto RESTful API for full set of returned names

"Display the parsed value in an cell

ws.Cells(3, 2).Value = tempStr "Write the value to a cell

4. Saveall changes.

Your macro should appear as shown here:

E Microsoft Visual Basic for Applications - Book1.xlsm
File Edit View Inset Format Debug Run  Tools Add-lns  Window Help

EE-A Bal9 b0 @ S EFY @ Lncolis

-l
Project - VBAProject “)SJ [

) Bookl.xlsm - Sheet1 (Code)

BE B | = LI IReadPoEnl Ll

E-8% VBAProject (Bookl.xlsm) =
[E-£25 Microsoft Excel Objects Sub ReadPoint ()
Sheet1 (Sheet1) ' Create an object reference to the Excel worksheet

-3 ThisWorkbook Dim ws As Worksheet: Set ws = Worksheets("Sheetl"™)
=-E5 Modules 'Create a string that will be the URL write command
g8l JsonConverter Dim strUrl As String

strUrl = "http://restpac.groov.com/api/vl/device/strategy/ios/analoglnputs/Lamp Temperature/eu”

'Build HITP request

Dim hReq &s New WinHttpRegquest

hReq.Open "GET™, strUrl, False

hReq.SetRequestHeader "Content-type™, "application/json"

hReqg.SetCredentials "rw", "rw", 0 'Replace username and password with name and password defined
hReq.Send

'Read the return from the PAC. The return information will be a JSON string
Dim strResp As String
strResp = hReq.ResponseText
'Create an object using the JsonConverter library to read the walue from the JS0N string.

ws.Cells (2, 2).Value = strResp

' Dim json As Object _—
Set json = JsonConverter.Parsedson(strResp) 'Use MIT JsonConverter class
Dim tempStr As String
tempStr = json({"value™} '"value™ is the name returned in the J50N. For digital points, use "state"
'See the Opto RESTful APT for full set of returned names

'Display the parsed value in an cell
ws.CellstS‘, 2) .Value = tempStr 'Write the wvalue to a cell

End Sub

4
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Test

1.  Return to the Excel sheet.
2. Click Read Point.

Cell 3B displays the parsed value:

Book1 xism - Excel

Home Insert Page Layout Farmulas Data Review View De ACROBAT Q Tell me what

=== 3 Record Macro a & ’—_"ﬂ' ﬁ. =] Properties FE TR Map Properties [ Import

T
Add- Excel COM | Insert Design

& View Code = ~ 1 Expansion Packs [, Export
(3 b rce
! Macro Security ins Add-ins Add-ins | =  Mode ] RunDialog £ Refresh Data
Code Add-ins. Contrals :

{"value":7.05953064e+01}

70.3953064
Read Point

FOR FURTHER EXPLORATION

The Excel sample OptoRESTfulPAC xIsm contains interactive spreadsheets to build any read or write command
supported by your PAC. Also in this file is a sample chart that plots data on a time interval. These samples
construct the URL paths and parse the various forms of data returned, in addition to writing to the PAC.
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